[lammps-users] LAMMPS hold on when using BNCH.ILP but no output

Hi All,

I’m trying to using BNCH.ILP to simulate pure h-BN systems,then I found LAMMPS hold on but no output and no error massages.

I need to replace the interlayer potential of h-BN from pair_style lj to pair_style ilp/graphene/hbn and coul/shield.

Then,I used atom_style full and modified data file.I have complied lammps-29Sep2021 with MANYBODY,MOLECULE,INTERLAYER packages on Linux system.

I found that the log.lammps still 0 bytes and no output,even though I’ve run 24 hours.

What confuses me the most is that LAMMPS doesn’t give any error massages and keeps running.I’ve never seen this situation.

I save the screen output to the log file with the >log command.The log file not update after reading potential files as follows:

Reading tersoff potential file BNC.tersoff with DATE: 2013-03-21

Reading ilp/graphene/hbn potential file BNCH.ILP with DATE: 2020-01-16


Your simulation uses code contributions which should be cited:

  • ilp/graphene/hbn potential doi:10.1021/acs.nanolett.8b02848

The log file lists these citations in BibTeX format.


WARNING: Using ‘neigh_modify every 1 delay 0 check yes’ setting during minimization (src/min.cpp:188)

For simplify,I use a official example file which named in.bilayer-hBN.lmp.

I can run in.bilayer-hBN.lmp sucessfully in version of “LAMMPS 64-bit 9Oct2020-MPI” on Windows systems,but once I run it on Linux system,there wil be same situation like before.



What is the exact version output from your LAMMPS executable?

This sounds like you are running across a bug that was fixed in the first update to the stable version (and is also in the recent patch releases). So it would suffice to redownload the sources from lammps.org and configure/compile again or download the latest update patch from github and apply to your source and then recompile.

Thank you for your help!

I have now successfully solved the problem.

I download the stable version of lammps-29Sep2021 in October 2021, and then compile with this tarball.Now I download the latest lammps-29Sep2021 stable release and the problem was solved!

Thanks again!