[lammps-users] lammps with openmpi

Hello,

I have errors when compiling LAMMPS with openmpi. I use modifed Makefile.openmpi for my Centos5.1 OS

My system specific settings

Those aren't LAMMPS variables it is flagging.

Steve

Wende,
First try to run test examples provided by openmpi. If you can run those. Then try lammps. Also see the discussion on similar problem couple of days ago.

Regards,
Vikas

2008/6/23 Steve Plimpton <[email protected]…24…>:

Wende,

First try to run test examples provided by openmpi. If you can run
those. Then try lammps. Also see the discussion on similar problem
couple of days ago.

if i may add one more comment. since your openmpi installation is
in a non-standard directory, it is quite likely that your mpic++
is actually coming from a different mpi installation. did you adjust
your path? for a proper openmpi installation, you should not need to
specify the include directory or the libraries anyways. that should
be done by the mpic++/mpicc/mpiCC wrappers automatically.

cheers,
   axel.

Regards,
Vikas