[lammps-users] Lost particles with Gay-Berene potential and setting the lattice spacing manually

Dear lammps user,

My lammps version is 29 Oct 2020 .

I am trying to simulate ellipsoids as explained in the below script. My ellipsoid aspect ratio is 3.5. As the LJ particle density (rho^*=0.3), LAMMPS generated the lattice spacing for the simple cubic lattice equaling 1.494 . Once I run the LAMMPS script with the setup explained in the below script, my particles are lost from the simulation box and I end up having very few particles.

According to my understanding, the problem is due to the overlap between the ellipsoids in the initial setup since the lattice spacing is smaller than the major axis of an ellipsoid.

I tried to set up the lattice spacing mcaullay using the following command, but still the particles are lost from the simulation box.

lattice custom 0.3 spacing 3.5 3.5 3.5 basis 0 0 0

Could you please help understand my mistake ?

I just try to extend the lattice spacing and put one basis particle in the unit cell.

Best regard

Overlapping initial positions are not the only reason for lost atoms.

what you need to be doing is not changing the geometry (you cannot really do that without also changing the density) but rather come up with ways to drain the excess energy from your system.

one option to do that is via adding friction. e.g. by using fix langevin with a low target temperature and a very short relaxation time while also (temporarily) reducing the timestep.

there are other problems with your input:

  • you don’t compute the temperature correctly. the default temperature compute is considering point particles and thus knows nothing about the additional degrees of freedom of your ellipsoids
  • you are using the wrong time integration fix. some as compute temp it only considers point particles and thus does not update orientations of your ellipsoids.
  • same goes for fix langevin, but that doesn’t matter in the initial stages of equilibration. in this case it helps to remove kinetic energy quickly.
    to address this you can start your equilibration with something like this:

thermo 10

timestep 0.0001

compute atemp all temp/asphere
thermo_modify temp atemp
fix 1 all nve/asphere
fix 13 all langevin 0.1 0.1 0.0001 369

run 1000

you can see how the excess energy is quickly drained from your system.
and then switch to a nose-hoover thermostat for the actual target temperature to continue equilibration

unfix 1
unfix 13
fix 1 all nvt/asphere temp 1.0 1.0 0.01

thermo 100
thermo_style custom step temp pe ke etotal
run 30000

and then switch to production simulation with a longer time constant (i.e. a more weakly coupled thermostat).