[lammps-users] Multiple processors (PPPM?) problems

Hello, first time poster with some quirky problems. Let us focus in the situation in which I have the most power. I apologize for the length.
I run Intrepid Ibex 8.10 Ubuntu 64-bit edition on an Intel Core 2 Duo processor. I have root privileges to my machine. I prefer to install packages through the apt-get mechanism, and have installed MPICH and FFTW in this way, though I am not afraid of installing from source.

sudo apt-get install build-essential mpich-bin libmpich1.0-dev mpi-doc fftw2 fftw-dev libxaw7-dev

Then, with the surprisingly simple makefile (src/MAKE/Makefile.telemann) I can compile LAMMPS (23 Jan 2008) with a simple “make telemann” command in the src directory. I am using mpicxx as my compiler and linker. -mpiversion reports the MPICH version data following the makefile.

I don't think it's a LAMMPS problem - I think it is a problem
with the way you've configured FFTW or MPICH. I would
install FFTW yourself, following the directions in the LAMMPS
manual about which version to get. It's a simple ./configure; make
for any system I've tried it on.