[lammps-users] NVT Temp not match the desired one

Dear Haibin,

I am not that experience in MD.But from my small experience,I found few things-
As Axel and John told already that u need to allow the system to go for equilibrium in longer simulation time and setting the initial temp. to a higher value, I would like to suggest that again in a different style.

As it seems your system is a CNT and the size is not that big.How about setting the initial temp. to higher value like 800 and go for nve.Go for run certain times.It will drop down to around 500.Then unfix it and set the temp to 500 and turn on NVT.I think it will help more to achieve the desired temp.However,as it seems to be a small system, I think it will take long time to equilibrating to desired temp.

If it dose not help yet, try langevin thermostat along with nve in the 1st ensemble.May be that will help more.
Hope it will help.If I am wrong,plz somebody correct me.

Best regards,