[lammps-users] "Out of range atoms, cannot compute PPPM" or "Non-numeric atom coordinate, simulation unstable" after delete some atoms

Dear all,

I am performing a simulation, in which some atoms in system are deleted periodically and perform nvt for atoms remained. I am using command “variable loop”, “label”, “delete_atoms”, “next” and “jump” to achieve the process, and my simulation box is non-orthogonal box, gamma > 90°. I found the simulation performed completely in first loop. When the simulation come to the second loop, that is, some atoms was deleted, the error “Out of range atoms, cannot compute PPPM” or “Non-numeric atom coordinate, simulation unstable” was triggered. However, the potential energy and total energy is normal, so I think there is not overlapped atoms. Except that, the system data file after deleting some atoms in first loop was outputted through “write_data”, and I used the data file for same simulation, the first loop nvt is normal, and the second loop is the same error. I have no idea about that. Could you give me some suggestions?

Best regards.
Dongbo Wang

I suggest you remove the loop logic and write a simple-as-possible script
that performs the first simulation, deletes atoms, performs the second simulation.
If the 2nd simulation gives the same error, then you have something much
simpler to debug. If it doesn’t then, your looping is not working the way you think.