[lammps-users] Package error

Dear Lammps users,

I just now installed the new stable version -LAMMPS (29 Sep 2021) for brownian dynamics simulation:.

$ ./lmp_serial < chromatinfinal2.in

ERROR: Unrecognized atom style ‘full’ is part of the MOLECULE package which is not enabled in this LAMMPS binary. (…/atom.cpp:740)
Last command: atom_style full

I used “make” for installation of this stable version. For the above error, I found the answer both from the mailing list and the documentation :
" If you get a run-time error that a LAMMPS command or style is “unknown”, it is often because the command is contained in a package,

and your build did not include that package " / Lammps should be built again after installation of packages.

I tried the following steps that I followed for October 2021 version:

make yes-all

./lmp_serial -h # I found that the atom style " full " is missing. Similarly the fix style “brownian”
is missing.

After installing all the packages I used " make serial" to enable but still its missing. Am I still doing any mistake?

I have attached the screenshots.

“make yes-all” will most likely not work unless you do a lot of extra work compiling and installing a whole bunch of external libraries and libraries in the lib folder of LAMMPS.
And most of that needs to be done before you do a “make yes-all”. You most certainly need to read about this in the detailed build instructions. Without the proper preparations you will get an error and LAMMPS will not be compiled, so you will retain a previous executable without those packages.

My recommendation is to delete everything and start over. Then you can first try compilation without any packages with “make serial” (and then probably also with “make mpi” to see if you can get a parallel executable). Then you can use “make yes-basic” to install a few commonly used packages followed by “make serial” (and optionally by “make mpi”) to see if that works. that executable will than have more features enabled and be able to run more inputs. and from there on you can either read the documentation and selectively install individual packages that you want to use and carefully follow the instructions in the manual, or just use “make yes-most” to have all “safe” packages installed, i.e. those that do not depend on external libraries or having to compile code in the subdirs of the lib folder. if you are still missing things, you can then still add features, but you may first have to do “make lib-XXX” with “XXX” being specific to individual packages and follow the instructions in the manual.

However, for atom style full and the MOLECULE package the “make yes-basic” step is sufficient.

Thank you Axel and it works now. I followed the steps you have given till make yes-most and the atom style error is gone now.

Getting only the following error:
ERROR: Unrecognized fix style ‘brownian’ is part of the BROWNIAN package which is not enabled in this LAMMPS binary. (…/modify.cpp:908)
Last command: fix 1 all brownian 1.0 12908410 gamma_t 1.0.

I am reading the documentation to fix this error to install and enable the brownian package


Fixed both atom style and fix style errors following your instructions carefully.I am able to run my code now.
thank you so much Axel