[lammps-users] PRD Segmentation Fault

Hi Everyone,

I've just started to use the PRD package and I am experiencing some
funny behaviour.

I ran prd without specifying minimization values (from the manual,
default values are 40 50 0.1 0.1, should that be 0.1 0.1 40 50 instead?)
and what I find is that the simulation runs fine until the very end
where it produces a segmentation fault. The log files are able to
output the last step but dump file is terminated.

If I run the sample input script as is, it works fine (min = 1e-5 1e-5
100 100), but if I remove the values for minimization, the same error

Strangely enough, if I use min = 40 50 0.1 0.1 it runs without error,
but min = 0.1 0.1 40 50 gives a segmentation fault.

To me, this seems like there could be a small bug in the package. Or
perhaps there is a logical explanation for this?

Is anyone else able to reproduce these results?

I am running the 15 Jan 2010 version of LAMMPS, and here is the exact
output of the error I get:

[localhost:18549] *** Process received signal ***
[localhost:18549] Signal: Segmentation fault (11)
[localhost:18549] Signal code: Address not mapped (1)
[localhost:18549] Failing at address: (nil)
[localhost:18549] [ 0] /lib/libpthread.so.0 [0x7f626480fa10]
[localhost:18549] [ 1] /lib/libc.so.6(strlen+0x30) [0x7f6264526ff0]
[localhost:18549] [ 2] lmp_openmpi(_ZN9LAMMPS_NS6Output5writeEi+0x294)
[localhost:18549] [ 3] lmp_openmpi(_ZN9LAMMPS_NS3Min3runEi+0x204)
[localhost:18549] [ 4] lmp_openmpi(_ZN9LAMMPS_NS3PRD6quenchEv+0x7c)
[localhost:18549] [ 5] lmp_openmpi(_ZN9LAMMPS_NS3PRD7commandEiPPc+0xaa8)
[localhost:18549] [ 6]
lmp_openmpi(_ZN9LAMMPS_NS5Input15execute_commandEv+0xa13) [0x5f8b13]
[localhost:18549] [ 7] lmp_openmpi(_ZN9LAMMPS_NS5Input4fileEv+0x3fa)
[localhost:18549] [ 8] lmp_openmpi(main+0x4a) [0x60030a]
[localhost:18549] [ 9] /lib/libc.so.6(__libc_start_main+0xe6)
[localhost:18549] [10] lmp_openmpi(_ZNSt8ios_base4InitD1Ev+0x41)
[localhost:18549] *** End of error message ***
mpirun noticed that job rank 0 with PID 18549 on node localhost exited
on signal 11 (Segmentation fault).
1 additional process aborted (not shown)


I'll look at this when I'm back in the office. Trust the
sample input script, not the doc page. It may be that
the min args are listed backwards on the doc page.
But it still shouldn't crash at the end. How many procs
are you running on?



I am running with 2 processors.