[lammps-users] Problem compiling LAMMPS (g++ parallel)

Hello Friends,
II am trying to make LAMMPS on a 128 node cluster operating on RED HAT ENTERPRISE EDITION 5.3 using Intel g++ Libraries.However I am getting errors when I try to make LAMMPS.

The error goes like:

…prism.o region_sphere.o region_union.o remap.o remap_wrap.o replicate.o respa.o run.o set.o shell.o special.o temper.o thermo.o timer.o universe.o update.o variable.o velocity.o verlet.o write_restart.o xdr_compat.o -lmpich -lpthread -lfftw -o …/lmp_g++
/usr/bin/ld: cannot find -lmpich
collect2: ld returned 1 exit status
make[1]: *** […/lmp_g++] Error 1
make[1]: Leaving directory `/home/nandu/Desktop/lammps/src/Obj_g++’
make: *** [g++] Error 2

Any idea why this occurs?Could anyonyone tell me which folder should I mention in the MPI_PATH??

Regards,
Nandu Gopan

My g++ make file is:

g++ = RedHat Linux box, g++, MPICH2, FFTW

SHELL = /bin/sh

---------------------------------------------------------------------

compiler/linker settings

specify flags and libraries needed for your compiler

CC = /home/nandu/Desktop/openmpi/prefix/bin/mpicc
CCFLAGS = -g -O -I/home/nandu/Desktop/fftw/prefix/include -DFFT_FFTW -DOMPI_IGNORE_CXX_SEEK -DOMPI_SKIP_MPICXX
DEPFLAGS = -M
LINK = /home/nandu/Desktop/openmpi/prefix/bin/mpicc
LINKFLAGS = -O -L/home/nandu/Desktop/openmpi/prefix/lib -L/home/nandu/Desktop/fftw/prefix/lib
USRLIB = -lfftw -lmpich
SYSLIB = -lpthread -lstdc++
ARCHIVE = ar
ARFLAGS = -rc
SIZE = size

---------------------------------------------------------------------

LAMMPS-specific settings

specify settings for LAMMPS features you will use

LAMMPS ifdef options, see doc/Section_start.html

LMP_INC = -DLAMMPS_GZIP

MPI library, can be src/STUBS dummy lib

INC = path for mpi.h, MPI compiler settings

PATH = path for MPI library

LIB = name of MPI library

MPI_INC = -DMPICH_IGNORE_CXX_SEEK
MPI_PATH =
MPI_LIB = -lmpich -lpthread

FFT library, can be -DFFT_NONE if not using PPPM from KSPACE package

INC = -DFFT_FFTW, -DFFT_INTEL, -DFFT_NONE, etc, FFT compiler settings

PATH = path for FFT library

LIB = name of FFT library

FFT_INC = -DFFT_FFTW
FFT_PATH =
FFT_LIB = -lfftw

additional system libraries needed by LAMMPS package libraries

these settings are IGNORED if the corresponding LAMMPS package

(e.g. gpu, meam) is NOT included in the LAMMPS build

SYSLIB = names of libraries

SYSPATH = paths of libraries

gpu_SYSLIB = -lcudart
meam_SYSLIB = -lifcore -lsvml -lompstub -limf
reax_SYSLIB = -lifcore -lsvml -lompstub -limf
user-atc_SYSLIB = -lblas -llapack

gpu_SYSPATH = -L/usr/local/cuda/lib64
meam_SYSPATH = -L/opt/intel/fce/10.0.023/lib
reax_SYSPATH = -L/opt/intel/fce/10.0.023/lib
user-atc_SYSPATH =

---------------------------------------------------------------------

build rules and dependencies

no need to edit this section

include Makefile.package

EXTRA_INC = (LMP_INC) (PKG_INC) (MPI_INC) (FFT_INC)
EXTRA_PATH = (PKG_PATH) (MPI_PATH) (FFT_PATH) (PKG_SYSPATH)
EXTRA_LIB = (PKG_LIB) (MPI_LIB) (FFT_LIB) (PKG_SYSLIB)

Link target

(EXE): (OBJ)
(LINK) (LINKFLAGS) (EXTRA_PATH) (OBJ) (EXTRA_LIB) (LIB) -o (EXE) (SIZE) $(EXE)

Library target

lib: (OBJ) (ARCHIVE) (ARFLAGS) (EXE) $(OBJ)

Compilation rules

.o:.cpp
(CC) (CCFLAGS) (EXTRA_INC) -c <

.d:.cpp
(CC) (CCFLAGS) (EXTRA_INC) (DEPFLAGS) < > @

Individual dependencies

DEPENDS = (OBJ:.o=.d) include (DEPENDS)

Regards,
Nandu Gopan

I guess your system administrator of your cluster will tell you the
MPI_PATH. It is highly unlikely that one of us in the list would know
the MPI-PATH of your Linux Cluster.

Else ask anyone who is running parallel programs using MPI on the cluster.
Best'
Manoj

2010/1/20 NANDU GOPAN <[email protected]>: