[lammps-users] Problem in running simulation using ReaxFF on a supercomputer

Dear Lammps Users,

I have a problem in running simulation using ReaxFF, which I highly appreciate if you could help me to solve. The problem is whenever I run my script (you can find it in the attachment) on my own computer (Lammps version 3 March 2020) it goes without any error. But when I run it on our university supercomputer (Lammps version 12 December 2018) in the middle of the simulation, I get the following error:
step202000-hbondchk failed: H=0 end(H)=0 str(H+1)=-2064056616

input_diatomic.in (5.89 KB)

are the systems and length of simulations exactly the same on both machines and with exactly the same number of processors?
this kind of error would happen either if your system “changes too much” (LAMMPS uses some initial guess of how much storage would be needed for hydrogen bond interactions, and if you need more, e.g. when your system is rearranging or condensing, then you could get into a situation where this initial estimate is no longer suitable.
this is more likely when you use more MPI ranks.

a workaround would be to write out restarts and stop the LAMMPS run after some interval to have it determine a new and more suitable guess when restarting.
with a more recent LAMMPS version you can also set a minimum hydrogen bond storage size as optional parameter.