[lammps-users] running lammps with ewald and compiling issues

Dear lammps developer/users,
We’ve been trying to use the latest version of lammps package on one of the teragrid sites ([email protected]…1870…69…).
I always encountered problems when using ewald sum for long range electrostatic interactions, it worked fine without ewald though. The help staff there told me no one complained about running lammps there before, but they also observed the same error using my input files. However, I’ve tested my input files on our own cluster without any problems. I’ve attached my input files and the Makefile which was used to build lammps on steele.
I would really appreciate if anybody could test the case and advise me what went wrong here?
btw, the libraries used there are also listed below:
libmpich.so.1.1 => /apps/rhel5/mpich2-1.1.1p1/64/nemesis-intel-11.1.038/lib/libmpich.so.1.1 (0x00002b6941df1000)
libsfftw.so.2 => /apps/rhel5/fftw-2.1.5/mpich2-intel/lib/libsfftw.so.2 (0x00002b6942196000)
Thank you very much.
Jihang

in.graph (1.08 KB)

lammps_GRA_1 (422 KB)

Makefile.rhel5 (2.38 KB)

you are linking to the single precision version of fftw.
that cannot work. you need the double precision version.

cheers,
    axel.

Axel is correct - but note that for Ewald you don't need FFTs.
If you mean PPPM (or particle-mesh Ewald) then you do
need them.

Steve

Thanks both of you for your comments.
I do need pppm, so I’ll use the fftw libs.
I think I’ll change the compiling option from “-lsfftw” to “-ldfftw”, is that it?
Thanks again.

See several of the Makefiles in src/MAKE that link
to the FFTW lib for examples of how to do this.

Steve