[lammps-users] segmentation fault

Why would I get a segmentation fault in my simulations using
kspace_style pppm and not in simulations using ewald? I have made sure
the box is large enough to contain the atoms and the timestep small
enough to prohibit losing atoms.

Christina Payne
[email protected]

Hi Christina. You might try “pair_modify table 0” to turn off the tabulation of the real space portion, but this will probably slow things down by about 2x. Or make sure you are not using any -O3 or high level optimization flags in your makefile. You might also try playing with the pppm precision setting — try “kspace_style pppm 1.0e-5”, which will also slow things down, but may help. If it is crashing immediately, there may be something else wrong. -Paul