[lammps-users] shake + respa

Hi All,

I just started using lammps but I haven't been able to run with SHAKE and RESPA. I tried different builds (Linux and Mac OS) and got a similar outcome. The problem is as follows:

- if I'm running with RESPA and I set the frequency to print SHAKE statistics to zero (the "N" parameter in the shake fix), I get a segmentation fault.

- If I set the "N" parameter to any number > 0, I get the SHAKE statistics printed EVERY time step.

I have no problem whatsoever running with RESPA without SHAKE or using SHAKE without RESPA. The problem seems to be independent of the build, since I've tried several compilations in a Linux cluster (amd64) and in a couple of multi-core Macs, and got similar results. I used the May-1st download in all cases. I've also tried different simulation systems.

Allow me to illustrate with the "peptide" example. If I add the run_style command as (with N=100 in shake fix)

fix 1 all nvt temp 275.0 275.0 100.0 tchain 1
#fix 2 all shake 0.0001 10 100 b 4 6 8 10 12 14 18 a 31
fix 2 all shake 0.0001 10 100 b 4
run_style respa 2 2 inner 1 4.0 5.0 outer 2

I get the following in the log file

SHAKE stats (type/ave/delta) on step 0
   4 1.111 1.44264e-05
SHAKE stats (type/ave/delta) on step 0
   4 1.111 1.44264e-05
Memory usage per processor = 11.3218 Mbytes
---------------- Step 0 ----- CPU = 0.0000 (sec)

Looks like some debug code was left in by accident. I'll post
a patch later this AM. Also note that there is a known problem
with the pressure being incorrectly calculated when running
rRESPA + SHAKE. This is just diagnostic output when
running NVE or NVT. But if you run NPT then the incorrect
pressure will drive the system to the wrong volume.

We should have a fix for this soon, in the context of the new
Nose-Hoover fixes Aidan recently released.