[lammps-users] Sucessfully compiled all package, but GPU doesn't work

Hi All,

With some good effort, I manage to compiled all the packages on Centos 5 Linux node. I ran a few non-GPU examples, and they worked very well.

However, I got the following error when I ran it:
[[email protected]…2159… bench]$ …/src/lmp_linux < in.lj.gpu
LAMMPS (12 Oct 2010)
Lattice spacing in x,y,z = 1.6796 1.6796 1.6796
Created orthogonal box = (0 0 0) to (33.5919 33.5919 33.5919)
1 by 1 by 1 processor grid
Created 32000 atoms
ERROR: Cannot use newton pair with GPU lj/cut pair style
Cuda error in file ‘nvc_memory.h’ in line 435 : invalid texture reference.

I couldn’t find any help on this error. I built LAMMPS with OpenMPI compiled with intel compiler. The math library is intel MKL. And CUDA version is 3.0

The pair_style that I modified is:
pair_style lj/cut/gpu one/node 0 2.5

On this node, there are two Tesla C1060 GPUs:
[[email protected]…2159… bench] ../lib/gpu/nvc_get_devices Device 0: "Tesla C1060" Revision number: 1.3 .... Device 1: "Tesla C1060" Revision number: 1.3 .... [[email protected] bench]

Do I miss anything simple? Any help will be really appreciated, and let me know if you need any further information about the compilation or our system.

Thanks in advance,

Kai

You must add Onewton off¹ to the script.

The GPU package in the main distribution needs to be updated. If you want to
use GPU acceleration, please use the code at:

http://code.google.com/p/gpulammps/source/checkout

and read the new README in lib/gpu and documentation in
doc/Section_start.html under running on GPUs as this has changed.

There is also a USER-CUDA package in there that you might want to check out.

- Mike

Hi Mike,

I added “newton off” at the beginning of the input file, and it works now. Thanks a lot.

For some reason, I can’t check out the code:
svn checkout [http://gpulammps.googlecode.com/svn/trunk/gpulammps-read-only](http://gpulammps.googlecode.com/svn/trunk/gpulammps-read-only) svn: URL '[http://gpulammps.googlecode.com/svn/trunk/gpulammps-read-only](http://gpulammps.googlecode.com/svn/trunk/gpulammps-read-only)' doesn't exist

But I can browse all the files. I found out there are lots of changes recently. Is there a way for me to get the updated version?

Thanks again,

Kai

Kai,

It looks to me like you’re using the wrong URL. Try getting rid of the gpulammps-read-only part:

svn checkout http://gpulammps.googlecode.com/svn/trunk

Paul

Need a space between trunk/ and gpulammps-read-only.

_strongly_ recommend using this code.

- Mike

Thanks! I am able to check out the code now!

Hi Mike,

The compilation went smooth until I ran “make linux” in the $LAMMPS/src direcotry. I got the following error:

For USER-CUDA package, you should probably contact the developer directly:

Christian Trott <[email protected]>

I can only help with the GPU package.

- Mike