[lammps-users] thermo_style error

Hi, All
With the recent version(Jan 09 ), an error was hit while I tried to output stresses. I tried input file as a copy from the manual.

compute		peratom all stress/atom
compute		p all reduce sum c_peratom[1] c_peratom[2] c_peratom[3]

variable	press equal -(c_p[1]+c_p[2]+c_p[3])/(3*vol)
thermo_style	custom step temp etotal press v_press 

The error message was “Per-atom virial was not tallied on needed timestep”. However, if v_press was removed from the thermo_style command, the error was gone. This problem did not exist in the last version. Does anyone have any ideas about this? Thanks.


This is a bug in how compute reduce interacts with compute stress/atom.
It didn't get changed to the new methodology in the 9Jan09 release.
I'll post a patch this AM.


Hello Steve,

I think there is still some problem with the compute command in the new version,
even after patching the Jan 16 patch.

I have a script which contains the following part:

yes - this shows up another bug from the 9Jan09 release.
I'll post another patch today.