[lammps-users] Why the atoms in my system lost?

Dear LAMMPS users,

I have a problem with atom lost in my system. My system is simply a box of some ellipsoidal particles. (I used LJ units) First, I created a region using this command:

Lattice sc 0.02

Then I created a box in this region by using this command:

Create_box 2 mybox

And finally I filled this box with atoms by using this command:

Create_atoms 1 box

In this system, I fill my box with some particles of type 1 and then I change a specific fraction of atoms from type 1 to type 2. This is why I used “2” in the “create_box” command. Actually because finally I will have two types of atoms in the box. When I want to run this program, some of my atoms become LOST! I don’t know why this happens! For example, when I have 8000 atoms initially in the system, after the first step running MD, the number of atoms becomes almost 7100!! I tried several numbers of atoms but every time, a part of my atoms become lost and I could not find out what is the reason. I am sure that my particles do not overlap with each other. Because I put the particles on a simple cubic lattice sites and the size of the particles and the lattice constant have been set in such a way that no overlaps can occur between particles. Therefore if I want to run MD to this system I have to use a command to ignore the atom lost which is not desired for me!

Would you please help me to understand what is going on in my system?
Thanks a lot,

Probably because the ellipsoidal particles you are creating are overlapping
in some manner, and get blown out of the box when you start dynamics.
Or your timestep is too big, etc.

The ellipsoidal potentials (e.g. GayBerne) are quite stiff, and if you
have overlaps, you will do catastrophic dynamics.


Dear Steve,

I have used REsquared potential for my ellipsoidal particles and my particles are actually spherical not ellipsoidal! Because I have defined their shape with this command:

shape 1 1 1 1

which means than atom_type 1 has radius 1 in x and y and z directions. So my particles are sphere! I put them on simple cubic lattice sites with lattice constant much greater than particles radius. So I think there would be no overlaps exist in the system. But I will check the potential cutoff again.

I will try using a shorter timestep too, hope not to lost my particles this time! :slight_smile:

Thank you so much,

Dear Steve,

My timestep was toooooo big!!
I decreased the timestep and my problem became solved. Now my particles do not lost and I am happy! :slight_smile:

Thank you again.