Linking error while using USER-VTK package

Dear Community,

I compiled and linked LAMMPS successfully with VTK 7.1.

Previously, this was already tried but the solution was never posted (

Here is the content of the lammps/lib/vtk/Makefile.lammps file:

# Settings that the LAMMPS build will import when this package library is used

thanks for providing the info. we will include this as lib/vtk/Makefile.lammps.ubuntu18.04_vtk7 in the next LAMMPS patch.


Dear Dominik and LAMMPS users,

I am trying to use the dump custom/vtk command.I used "sudo apt-get install libvtk7-dev" command and I installed the **VTK7** 
but when i wanted to compile the LAMMPS (with Makefile.lammps.ubuntu18.04_vtk7) it gives this error  :

In file included from ../style_dump.h:9:0,
                 from ../write_dump.cpp:21:
../dump_vtk.h:32:10: fatal error: vtkSmartPointer.h: No such file or directory
 #include <vtkSmartPointer.h>
compilation terminated.

I also tried "sudo apt-get install libvtk6-dev" command instead and I installed **VTK6.3** but again one other error occurred (with Makefile.lammps.ubuntu14.04_vtk6) : 

1. Makefile.lammps.ubuntu18.04_vtk7 has to be renamed to Makefile.lammps or its content has to be copied to Makefile.lammps. Only Makefile.lammps is read during the linking after compilation.
2. If this does not help, check if the path of the linking arguments in the modified Makefile.lammps are correct, e.g. if the header files of VTK7 are in /usr/include/vtk7.1 ...


----- Mail original -----

Dear Dominik ,

Thanks for your reply .
I did exactly according to the LAMMPS manual but it gives the errors that i have mentioned in previous email.

It is hard to help, if you do not explain exactly what you did.

As I said, if you installed VTK7, if you have renamed the corresponding Makefile to Makefile.lammps, and if you still have a problem, then check the content of the modified Makefile.lammps.

According to your compiler message, "