lj vs real and velocity rescaling

Dear Lammps users,

I am trying to simulate a polydisperse colloidal system with SRD solvent particles.
for now I am using the polydisperse example from SRD example with minor changes in particle type.
When I use the script in LJ unit system it works fine but when I tried to switch the input to REAL unit system,
it started to give me rescaling problem. I am working towards gaining access to viscosity of the system.

similar questions have been asked before and I went through the answers but I am still not sure how to get out of this trouble.
from the answers it was clear that the problem arises due to the SRD particle creation and the setting are made for single particle type and as it shows only single particle in group small, so the problem lies there somehow??

I would appreciate any suggestion / help I can get to overcome this issue.

Thanking you


if you switch from reduced to real units, you have to change all relevant settings.
on top of that, you have to factor in that some commands have a different behavior and defaults with reduced or other unit settings. this applies for example to the lattice command.

as a consequence, you are creating a system with just 1 atom and for a single point particle in you cannot assign a temperature as its configuration is translationally invariant. hence the error on the velocity command.


The examples/UNITS folder has sample scripts for running the same problem
in different units. And a README. Doing it for a complicated fix srd script will likley
be more complicated. But it is do-able.


Thank you very much Axel and steve for your suggestions and directing me towards the proper things.
I will read on it and will work in converting the LJ input to proper REAL unit.