Make mpi problem

Hello everyone.

I’m modifying one of the fixes and sometimes after modification when I run ‘make mpi’ command in ‘src’ folder the terminal tells me “…/lmp_mpi is up to date.” And after launching a simulation my modifications are not included. What do I need to do?

Please provide more specific information:

  • which LAMMPS version you are using?
  • which fix (or fixes) you are modifying?

Or more general, please have a look at the guidelines and suggestions in this post for a list of best practices and suggestions on how you get the best/most help in this forum without forcing people to ask questions for information that needs to be provided.

I am using 3Mar_2020 version. The fix is Femto3d (I think it’s not an official fix).

This means that the file you have modified is not in the src folder with the other source files, but most likely in one of the USER-SOMETHING folders. Make sure the files you have modified are copied back where the binary is, by issuing something like make yes-USER-SOMETHING. Then make should compile the modified files and recompile the LAMMPS binary.

There are special make targets for this like “make package-update” (or “make pu”). Check out the list at the end of this manual section: 3.6. Include packages in build — LAMMPS documentation

1 Like

Thank you for your answers.

My fix is for sure in src folder and thus none of the makes of the manual worked for me.

You have to provide more context, as we do not read minds and can only formulate hypotheses on the information you share.

What you describe is not the expected behaviour of make. If there is a source file in src which is newer than the binary, then the file should be compiled and the binary rebuilt. The only possibility left is that this Femto3d stuff was never installed as a package. Does the folder with your custom fixes contain an file?

There is another one: the source of the fix was added, but it is incompatible with the LAMMPS source version and thus fails to compile and the resulting LAMMPS executable is the previous one without the fix included.

As @hothello stated, we need more context and a description of steps to reproduce the issue.
However, it should also be noted, that the LAMMPS developers have extremely little interest to debug and sort out issues with a 5 year old LAMMPS source code. We have moved on and always work with the latest version for new developments and are significantly more interested in helping with getting code updated (and - if useful to others - included into the distribution). There have been large improvements to code quality and reliability as well as portability over the last 5 years, so an update is highly recommended. That usually requires some update to custom code that was written for an older version of LAMMPS, but some information on what to do is provided in the developer info section of the LAMMPS manual at this link: 4.10. Notes for updating code written for older LAMMPS versions — LAMMPS documentation