I just tried to compile lammps (Aug 11/2017) in stampede. According to the suggestion in the lammps website, I tried to type
make stampede.

However, it complained that it could not find the -ltbbmalloc in the end of compilation, since it was asked in Makefile.stampede,

LIB = -ltbbmalloc

I wonder if there is particular module for the user to load in order to find this library.


Maybe this helps:


Just a note that if you are running on Stampede 2, Makefile.knl will be a better choice than Makefile.stampede (which is built with offload for KNC coprocessors). They also have prebuilt modules for LAMMPS at TACC, but if they don't have the most recent stable version, I would request they add it as it includes more optimizations for these processors.

Best, - Mike

More detailed reply for the -ltbbmalloc problem:

The Intel(R) Threading Building Blocks is apparently free software, you can get the source code here:

The preferred option is to install the package for your distribution, for Debian/Ubuntu it should be libtbb-dev, which should also pull the runtime package libtbb2.

Or it should be also a part of the Intel Parallel Studio for Linux installation (where icc is). In that case you just need to specify the path in the corresponding MAKEFILE. In my case I simply added the full path e.g. to FFT libraries like this: FFT_LIB= -L/opt/intel/composer_xe_2015.1.133/tbb/lib/intel64/gcc4.4/

Last option is to remove both -ltbbmalloc and -ltbbmalloc_proxy from LIBS in the MAKEFILE. Then it should compile just fine. But I'm not sure if it has some negative effects on the speed.