MEAM Potential: Did not find all elements in MEAM library file

Hi All,

I am trying to model an oxide structure using a hybrid of meam and Buckingham potential. However, I am getting the error message “Did not find all elements in MEAM library file”, however, I could not find the problem. As far as I could check, all the elements (Cr, Co, Ni) are defined in the library.meam. I have attached the files below for duplicating the error (I apologize for lengthy email, I couldn’t attach files). I would appreciate any help about the reason of this error.

library.meam:
# elt lat z ielement atwt
# alpha b0 b1 b2 b3 alat esub asub
# t0 t1 t2 t3 rozero ibar

‘Co’ ‘hcp’ 12 1 58.933
5.2356147485 3.50 0.00 0.00 4.00 2.5000000000 4.41 0.90
1 3.00 5.00 -1.00 1.00 3
‘Ni’ ‘fcc’ 12 1 58.690
5.0842175782 2.56 1.50 6.00 1.50 3.5213917703 4.45 0.94
1 3.10 1.80 4.36 1.00 3
‘Cr’ ‘bcc’ 8 1 51.960
5.5800716432 6.49 1.00 6.00 1.00 2.8809778433 4.10 0.52
1 2.00 6.80 -8.00 1.00 3

pull.in:
# ------------------------ INITIALIZATION ----------------------------
units metal
dimension 3
boundary p p p
atom_style atomic

# ----------------------- ATOM DEFINITION ----------------------------
read_data CrCoNiO.lammps

# ------------------------ FORCE FIELDS ------------------------------
pair_style hybrid meam buck/coul/cut 10.0
pair_coeff * * meam library.meam Co Ni Cr NULL CoNiCrFeMn.meam Cr Co Ni NULL
pair_coeff 1 4 buck/coul/cut 619.8 0.3372 0.0 0.0 6.0
pair_coeff 2 4 buck/coul/cut 684.9 0.3372 0.0 0.0 6.0
pair_coeff 3 4 buck/coul/cut 641.2 0.3372 0.0 0.0 6.0
pair_coeff 4 4 buck/coul/cut 22764.3 0.1490 C 0.0 6.0
reset_timestep 0
fix 1 all box/relax iso 0.0 vmax 0.001
thermo 10
thermo_style custom step pe lx ly lz press pxx pyy pzz c_eatoms
min_style cg
minimize 1e-25 1e-25 5000 10000

data.lammps:
10 atoms
4 atom types
0.0 26.385 xlo xhi
0.0 218.4449 ylo yhi
0.0 1089.1476 zlo zhi

Atoms # atomic

1 1 2.6385 5.39026 2.17963
2 2 2.6385 1.15235 8.05112
3 3 2.6385 6.73093 5.30731
4 4 0.0 4.37756 0.0
5 4 0.0 8.32226 2.17963
6 1 2.6385 3.36485 6.53889
7 1 1.31925 1.0127 2.17963
8 1 1.31925 7.74241 6.53889
9 2 2.6385 7.60276 3.69186
10 2 0.0 1.15235 5.02666

CoNiCrFeMn.meam:
https://www.ctcms.nist.gov/potentials/Download/2018--Choi-W-M-Jo-Y-H-Sohn-S-S-et-al--Co-Ni-Cr-Fe-Mn/1/CoNiCrFeMn.meam

Thank you so much,
Mobin

The error is correct because your input is not correct. The documentation of the meam pair style explains at great length the meaning of the element arguments and their required order and how the mapping to atom types is performed. Your input is failing both conditions and the error happens because of the first since there is no element called NULL.

More importantly, your use of a hybrid potential setup to model oxides is bogus and unlikely to produce meaningful results.

Thank you so much for your quick response. I found my mistake in utilizing the MEAM potential and fixed it, and now the code is working properly. However, I have a question about the last paragraph of your email:

More importantly, your use of a hybrid potential setup to model oxides is bogus and unlikely to produce meaningful results.

Might I ask what you mean by this? Do you mean that using these two specific force fields together is wrong or overall I must not use hybrid model for modeling oxides?

Thanks.

Both.

Different oxidation states result in different behavior, just ask any decent chemist. The metal elements in the meam library are in oxidation state 0 for obvious reasons. In your use case they are not.

Also using pair_style hybrid is meant to model systems where the each substyle handles one compound. Then the error is small because you only use a less accurate potential for the inter-compound interactions but in your case the error must be large because of all interactions being at the interface between different substyles.

Thanks for the explanation. I need to learn more about the hybrid pair style. If I may ask one last question, would it have meaningful outcome if I use pair-wise potentials that are parameterized for the oxidized state of these elements?

There are different force fields for oxides available. Some are only suitable for bulk crystals others for more complex compounds. You have to figure out yourself from the descriptions of the individual force fields which are applicable to your simulation.

Using a hybrid pair style is even under the best circumstances only the second best choice, but also can be the worst.