Missing atoms error in hydrated system

Hi all,

I’m simulating the hydrated state of the polymer system (with water). I encountered the bond/atom missing errors at the beginning step or the middle steps (3000/150000fs or 131000/150000fs) depending on different parameters I tried to use. I have kept looking at some similar posts on the forum but still didn’t get it to work.

At first I used 0.5 and 1 fs timestep, the error came out at the beginning of the run. Then I used a smaller timestep, 0.2 fs, it could run a bit further. Previously I used the same MD protocol to simulate the anhydrous state of the polymer (without water molecule), it worked well and the outcomes were desirable. But the protocol didn’t work when I tried to add some water molecules to the system. I used tip4p/2005 water model and the shake command to constrain the water behaviours.

I have included the input file, polymer structure file (with 280 water molecules ), the log file and the error message. Since the total MD run took more than 2ns, I only included part of the MD cycle (50000fs nvt at 1000 degrees, 50000fs nvt at 300 degrees, and 50000fs npt at 300 and 2500 bar). The hydrated system contained 9488 atoms with water molecules randomly dispersing in the cell (757575 Angstrom) without overlaps. Any suggestion would be greatly appreciated!

diffusion.o7332302 (29.2 KB)
log.lammps (21.5 KB)
polymer_water.in (1.9 KB)
polymer_water.lmps (2.3 MB)

Many thanks,

You are using a 5 1/2 year old version of LAMMPS. If the issue would be cause by a bug in LAMMPS, there is a good chance that bug has been fixed since then. So you should try with the latest version of LAMMPS.

Unless you can produce an input deck that would trigger the issue with quickly on a small desktop machine with a few CPU cores, it is not likely that somebody will have a closer look. What you describe sounds a bit like you are using force field parameters that may not be compatible with each other. But that is something you are in a better position that anybody else to check.