ModuleNotFoundError: No module named 'icet.fitting'

I read an existing Database via ce =‘givenDatabase.ce’)
but always get the error: ModuleNotFoundError: No module named ‘icet.fitting’

I’m working on Version 2.2 of icet in a PyCharm-Envoirement on a Ubuntu Computer.

I dont understand how/why reading a cluster expansion would give this error. Could you provide the full error message/traceback and the script you are running?

Are you sure you have icet version 2.2?
As far I as remember in 2.2 there shouldn’t be a module icet.fitting.

After your answer, I tried some old Versions of icet on the database we still had and Version 1.3 worked, so it seems to be a Problem of the old database. My supervisor is now creating a new one since the old database of the structure still has a fitting problem.
It gives back a ValueError since the Cell Volume doesn’t seem to match up good enough. So this issue is ‘fixed’.

Was the cluster expansion originally created with an older version of icet? My guess is that this error could happen as a result of storing stuff in the metadata field of the cluster expansion. When we use I think we try to pickle.load that stuff, and if it is instances of classes that are no longer available it would fail, I think. Any line number from the error message might confirm this.

If I am right, the best solution I can think of would be the following slightly awkward approach: Install an older version of icet, read the cluster expansion, set the metadata property of the CE to None, and write the CE to a new file. Then go back to a more recent version of icet and read the CE without metadata.

Oops, saw your response after I posted.