Now that I have solved my mp-api version problem (using 0.35.1), the example on the “Querying Data” example works. It does also, however, return a depreciation warning the warning below and suggests that I use "MPRester.materials.summary " method be used installed of When I tried the statement “dir(MPRester.summary)”, there was no such method as “search”. Where is this suggestion documented and is it actually implemented?

with MPRester(MAP_KEY) as mpr:
    docs =["mp-149", "mp-13", "mp-22526"])
Accessing summary data through MPRester.summary is deprecated. Please use MPRester.materials.summary instead.
Retrieving SummaryDoc documents: 100%|█████████████████████████████████████████████████████████████████| 3/3 [00:00<00:00, 21326.97it/s]

Did you try dir(MPRester.materials.summary)?

Thank you for your help. I am consistently using a conda virtual environment and installing everything by pip (into the same python environment), but I was bitten by the problem where one can install something using pip in the shell, but the version Jupyter sees is not updated. I must admit, I still confused by this. I removed mp-api and reinstalled it within Jupyter using the escape command

!{sys.executable} -m pip install <package_name>

I have mp-api version 0.35.1 installed and the example statement works fine.

Would you be so kind as to post an example using the MPRester.materials.summary method?

Please see the examples in our docs: Examples - Materials Project Documentation HTH