MPRestError: REST query returned with error status code 404 on URL

hello. I was able to run successful code yesterday, but returned 404 today. I then tried using the official sample code, but it returned 404 as well. What’s causing it in this case, my network should be fine

Please update to the latest mp-api client version

Thank you very much. The update solved the problem, which really helped me a lot

Hi developers,

I believe I have already updated to the latest version, but I still encounter the same error when running the code above.

Do you have any idea what is the problem ?


Since the request is going to /thermo and not /materials/thermo, you likely still have an old version of the mp-api client. Double-check in your python shell, via

from mp_api.client import __version__

or, in your bash/zsh/…, via

pip freeze | grep mp-api

The version should be 0.33.1. If not, make sure to upgrade the client in the right python environment via pip install -U mp-api


Thank you so much! Works well now.

I tried to upgrade mine using the commands given, but my mp-api is still version

You might have to upgrade your python version

Hello tschaume,

I faced the same problem and solved it by updating mp-api.

I registered today and just want to say, thank you so much for your answers.

Best wishes

1 Like