Need help in creating LAMMPS files using moltemplate

Hi Altruist,
I am trying to create LAMMPS files for SDS (sodium dodecyl sulfate) using moltemplate in Linux. When I run the file, then it is showing an error “The number of columns in your data file does not match the LAMMPS atom_style you selected. Use the -atomstyle command line argument.)”. I have double checked everything, but couldn’t identify the problem. I checked the same type of work with decane molecules. That worked fine. Would you like to help me figuring out the problem? I badly need help in this case. I have attached the required files for your convenience. I am also copying @jewettaij here if he could help me.
Akash Talapatra
MS student, Virginia Tech (1.5 KB) (10.5 KB) (601 Bytes)

Hi Akash,
The moltemplate dev wrote a superb error message containing both the issue (wrong number of column) and the solution (use the -atomstyle command). Therefore what do you mean by “(I) couldn’t identify the problem”? Also I have doubts that you “have double checked everything”. What tests involving the -atomstyle command have you tried already?

1 Like