New installation of ovito basic launches ovito pro and asks for license key

I have been using OVITO basic on a couple of other computers but now I’m trying to get it running on a new Ubuntu machine. Every version I download is asking for a license key which I do not have anymore. Should I just go ahead and contact support to get my old invalid 45-day key or is there some workaround I am spacing on?

OVITO Basic does not need to be activated with a license key, sounds like you accidentally installed OVITO Pro.

Well, the version I downloaded claims to be basic but it is still asking for a key. I am away from my desk now but I will try again when I get home to quadruple-check that I didn’t do anything silly. But I tried downloading the basic side twice and it says ‘basic’ in the file path. Edit: I even tried downloading a previous version of the basic, the June one I believe.

Correction, only the folder the files are in claims to be basic, specifically named “ovito-basic-3.8.5-x86_64”. The actual program that launches does say pro and asks for the key.

It sounds like you already have a version of OVITO Pro installed on your computer that is launching instead of the new OVITO Basic version. This can happen for example if you are using a Conda environment that has the OVITO Python package installed. There the plain command “ovito” will start OVITO Pro, which is part of the package from the OVITO conda channel. If you want to start OVITO Basic, additionally specify a path to the executable, e.g. ovito-basic-3.8.5-x86_64/bin/ovito. Or, if you are already in the sub-directory bin/, enter ./ovito to make sure Linux will launch the executable located in the current directory and not the one in the global search path.

1 Like

This was my issue, thank you so much.