Nomad Oasis, publish functionality is missing

Hey Nomad,

on Nomad Oasis, I do not have the publish functionality. The section are not there. And I can not add other users to my unpublished data (Co-Worker/Reviewer). The button is not clickable. I added screen shots.

Best Micha

This might be a configuration issue. I see that your name is now showing on the top right where it says “Welcome …”. It should show the name that you gave when registering the account.

I am comparing the source code for this page with your screen shot. The frontend seems to have some mixed state about the user login. The guards to enable disable the publish, delete, manage user buttons for example fail, the guards that check wether you are an editor of the upload succeed.

Can you compare localhost:8001/nomad-oasis/gui/env.js with your nomad.yaml? Maybe post both here?


my nomad.yaml is:

  api_host: 'nomad1-dev'
  api_base_path: '/nomad-oasis'

  is_oasis: true
  uses_central_user_management: true

  jupyterhub_crypt_key: '973acffb2534c9862563e7dc6bcc5a7126d5603a1193fe5c020'
  hub_ip_connect: ''

  deployment: 'oasis at HZB'
  deployment_id: 'oasis_at_hzb'
  maintainer_email: '[email protected]'

    db_name: nomad_v1

    entries_index: nomad_v1_entries
    materials_index: nomad_v1_materials

and localhost:8001/nomad-oasis/gui/env.js is

window.nomadEnv = {
    'appBase': '/nomad-oasis',
    'northBase': '/nomad-oasis/north',
    'keycloakBase': '',
    'keycloakRealm': 'fairdi_nomad_prod',
    'keycloakClientId': 'nomad_public',
    'debug': false,
    'encyclopediaBase': '',
    'aitoolkitEnabled': false,
    'oasis': true,
    'version': {},
    'globalLoginRequired': false

The files look ok. I can only assume that running the proxy under 8001 is causing issues. I’ll try to run some tests for this and come back to you.

Hey Markus, when I run it from the Intranet it is the same issue, then I run it on nomad1-dev without localhost

Hey Markus, I also started to investigate this more. I get a CORS policy error:

This explains why my username is not displayed and it only shows three dots “…”. Maybe the rest is also related to this?

I try to see if i can find a solution, seems like some cross site scripting issue with the server

Best Micha

Hey Markus,

Could you replicate this?

Best Micha

I have the same issue with our bare Oasis at “Welcome …” We are using port 8000.


Error: Promised response from onMessage listener went out of scope
[KEYCLOAK] Estimated time difference between browser and server is 0 seconds keycloak.js:935:28
[KEYCLOAK] Token expires in 86400 s keycloak.js:939:32
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).
Uncaught (in promise) undefined
Error: Promised response from onMessage listener went out of scope

I changed the CORS policy for the userinfo. Thus, the CORS error should be gone and you should see the user name instead of ‘…’.

1 Like

But I could not reproduce the initial problem with the limited upload functionality. Even when running stuff under a different port like 8001, it seems to work.

Can confirm that the name is now shown for us. Steps 3 and 4 are shown under Upload (didn’t check what it was before).


There are other problems, e.g. The specified local_path cannot be found or is not a file. (400) when trying to auto-upload the examples but this would be out of topic here I suppose.

Hey Markus, now the other steps are also showing, as is the upload members button. This resolved the whole problem.

For me the matter is now closed thanks.
Best Micha

Is there a way for me to access your installation, to get a better picture?