out of range atoms- cannot compute pppm

sorry, I forgot to cc lammps.

dumping your input script to the mailing list is rarely helpful and it doesn’t answer my question. have you tried any other (e.g. even shorter) time steps. you seem to be compressing with an awfully high speed and considering the steepness of the potentials you are using, you may have to implement a set of potentials that is softer and won’t diverge as quickly.

in any case, you are not using any feature that has recent changes or is rarely used, so it is fairly safe to assume that the chances for hitting a bug are very low. this means that the problem is with your settings. to understand what you have to do, you need to carefully monitor and visualize your system around the time things go bad and that usually helps to find the solution. the symptoms you describe do match the assumption of too large a time step.


Have you tried using fix dt/reset? May be useful yet does not supersedes Axel’s advice of carefully monitoring whats going on with your run.

no sir I have not tried with smaller timestep than 0.01fs. I’m trying with smaller one and will post if I can overcome the problem.