[Ovito] Seems like bug while reading pdb files with Big Sur (or python 3.9)

Greeting! I’m using OVITO pro and it is definitely nice tool to visualize atomic topology or trajectory.

However, I think the new macOS (Big Sur) is not compatible to use OVITO with full-featured.

When I tried to read pdb files before upgrade my OS, the pdbImporter seems to be run well, and it catched particle information successfully as well as molecular (or residual) information.

However, after upgrading my OS to Big Sur, OVITO cannot catch all information for topologies.

In addition, my collage, who uses both MacOS and Windows, reported error that the gromacs coordination file is not read well, but in Windows it works without problem.

I guess there is something wrong with compatibility.

Can anybody give some advises to solve this problem?

Here’s screenshots (Please see the attribute section)

In MacOS

In Windows

Thx :slight_smile:

Hi,
I’m not sure, but I think the differences that you describe have nothing to do with the operating system version. It’s more likely that you simply installed a different version of OVITO after upgrading your OS. Could that be?

In OVITO 3.3.0, the PDB file reader has been replaced with a different implementation (see the version history). From a user perspective, this may seem like a step back, because the new PDB file reader imports fewer information from the file than the old one, in particular it tries to replace the PDB atom names with chemical element names.
The Windows screenshot seems to show an older OVITO version, which used to import additional particle properties when opening a PDB file.

Since we are not happy with the behavior of the current PDB file reader either, we have been working on an updated version for some time now. It will be part of the next larger OVITO release. If you like, you can try one of these development builds to test the updated file reader. Your feedback is appreciated.

https://www.ovito.org/download/testing/ovito-basic-3.4.4-dev-HEAD-e43ca2d-win64-bonds.zip
https://www.ovito.org/download/testing/ovito-basic-3.4.4-dev-HEAD-e43ca2d-macos-bonds.dmg
https://www.ovito.org/download/testing/ovito-basic-3.4.4-dev-HEAD-e43ca2d-x86_64-bonds.tar.xz
https://www.ovito.org/download/testing/ovito-basic-3.4.4-dev-HEAD-e43ca2d-win64-bonds.exe
https://www.ovito.org/download/testing/ovito-pro-3.4.4-dev-HEAD-e43ca2d-win64-bonds.exe
https://www.ovito.org/download/testing/ovito-pro-3.4.4-dev-HEAD-e43ca2d-win64-bonds.zip
https://www.ovito.org/download/testing/ovito-pro-3.4.4-dev-HEAD-e43ca2d-macos-bonds.dmg
https://www.ovito.org/download/testing/ovito-pro-3.4.4-dev-HEAD-e43ca2d-x86_64-bonds.tar.xz

I cannot comment regarding the Gromacs file without knowing your exact OVITO version(s) and/or the actual file your tried to import. In this case too, I don’t think this is a platform or OS related issue. It’s more likely a question of which OVITO version you are using.
-Alex

1 Like

Cool! Thanks very much :D!! It has been solved by upgrade to developer version!

When I upgrade my OS, there were many other issues about the OS, and I guessed the cause was the problem of the OS.

Since I used OVITO 3.3.0, and upgraded to 3.4.3, the problem was not solved. The Windows version is quite older version, right.

By the way, I think it is pretty convenient feature that we can handle several pipeline explicitly in OVITO-3.4.4-dev version.

Thanks again to your quick and kind feedback. :slight_smile:
-Seulwoo