PPPM with GPU and Triclinic Box

LAMMPS users,

I am currently running my triclinic box of atoms with pppm on my desktop and it runs fine.

When I try to run it on a GPU though (LAMMPS was built with the GPU package), I get the following error:

KSpace style does not yet support triclinic geometries

I tried using the pppm/gpu command, but the error is the same. Is it possible that support for triclinic geometries with PPPM on GPUs has not yet been done?

Do you know of any type of work-around for this?

Ben

LAMMPS users,

I am currently running my triclinic box of atoms with pppm on my desktop and
it runs fine.

When I try to run it on a GPU though (LAMMPS was built with the GPU
package), I get the following error:

KSpace style does not yet support triclinic geometries

I tried using the pppm/gpu command, but the error is the same. Is it
possible that support for triclinic geometries with PPPM on GPUs has not yet
been done?

Do you know of any type of work-around for this?

just use the CPU version of pppm. it will run concurrently with the
GPU accelerated pair style.
please note that also neighbor lists for triclinic cells are not
implemented with GPU acceleration, so they have to be done on the CPU,
too.

axel.

What do you mean when you say the CPU version?

kspace style pppm also gives the same error.

I also know I need the command:

gpu neigh no

for the neighbor lists

What do you mean when you say the CPU version?

kspace style pppm also gives the same error.

no. it won't.

I also know I need the command:

gpu neigh no

for the neighbor lists

there are lots of details missing here. i suspect, you enabling GPU
acceleration from the command line via the -suffix flag and not from
inside the lammps input, right?
in that case, LAMMPS will *always* request the GPU version for any
style, if it is available in the executable. in order to force using a
CPU version you have to add the command "suffix off" to your input to
disable suffix processing for the following command. with -sf gpu you
will *always* get pppm/gpu, regardless of whether you put pppm or
pppm/gpu in your input.

for details, please look up the explanations in the manual in the
general section about using GPU acceleration and in the explanation of
the suffix command.

axel.

I see, that fixed the issue. Thanks!