Problem installing and Running Lammps

I got 2 Nvidia K40 GPUs and tried to run Lammps with CUDA GPU acceleration on Ubuntu 12.04. I tried the following codes to install CUDA package but it would show me the following error.

:~/lammps-15May15/src$ python Make.py -p cuda -cuda mode=single arch=20 -o cuda lib-cuda file mpi

ERROR: -o args are invalid

Also I tried the following command and it would not work either.

:~/lammps-15May15/src$ python Make.py -p cuda gpu -gpu mode=double arch=31 -a lib-all

Installing packages …

Action lib-all …

building gpu library …

nvcc -I/usr/local/cuda/include -DUNIX -O3 -Xptxas -v --use_fast_math -Icudpp_mini -arch=sm_31 -D_DOUBLE_DOUBLE --cubin -DNV_KERNEL -o atom.cubin lal_atom.cu

nvcc fatal : Value ‘sm_31’ is not defined for option ‘gpu-architecture’

make: *** [atom.cubin] Error 1

ERROR: Unsuccessful build of lib/gpu library

I have installed CUDA 7.0 and I have ran a bunch of samples and they all seems fine.

When I tried to run Lammps with lmp_linux, lmp_serial and so on none of them works.

I believe I have installed Lammps correctly but I cannot make it to work.

Best,

Eddie

Comments below …

Steve

can you please try compiling/installing LAMMPS the conventional way,
i.e. without using Make.py.

axel.