Problem of gulp parallel in linux

I compile gulp 5.0 using mkgulp , using gcc-6.5.0 and mpi-4.1.5 ,and change mkgulp line 221 into

line 221
echo ‘SLIBS= -L/home/sydong/program/gcc6/gcc-6.5.0/lib64/ -llapack -lscalapack -lblas’ >> makefile

and command
./mkgulp -m -j 24

It compiles smoothly and I got gulp
But I use command

mpirun -np 2 gulp example1

in example file ,it runs for a long time but do not terminate and produce ebxample1.gout

When i run command

mpirun -np 1 gulp example1

the job finished with in a second
What is wrong ?
gulp 6.0 have similar problems

Can anyone please help me on how to compile a parrallel version of gulp works well?

If nothing is happening then this suggests the problem is not GULP, but your MPI installation. Have you tested a few basic MPI codes on your system (e.g pi calculator)? As the issue is specific to your machine, you’ll need to find your local Linux expert to help you explore what’s been set up incorrectly, as it’s hard to diagnose without access to your computer.

Sorry , I find gulp program indeed generate a gout file and two files gulptmp_3_4_1 and gulptmp_2_4_ contains nothing .
the command I run is

mpirun -np 4 gulp example1

example1.gin (523 Bytes)
example1.gout (8.5 KB)

Looks like the code hangs when it goes into Scalapack for the Hessian inversion.
You need to make sure that the libraries you are linking against are all compatible with the MPI version and compiler you are using, so you should talk to the sys admin for advice.

PS You can run example1 in serial as it takes a fraction of a second and isn’t a large enough calculation to make parallelisation worth while. Your real calculation may be the same, so test if you need parallelism before you spend a long time messing with your system configuration.

Ok,Thank you very much . The serial version works well .I will follow your advice and try to do my calculation in serial first.Thanks for such a quick responce .

This indeed a problem of my scalapack library .Now all works well .Thank you .