Problem wit fix rigid and fix deform

Dear all,

I am trying to run a NEMD simulation with rigid bodies. I am using the command:

fix 2 all deform 1 xy erate 0.01 remap x flip yes

My run stops with the message:
ERROR: Lost atoms: original 81 current 9 (…/thermo.cpp:398)

This happens exactly when at the moment the flip takes place. If I specify “flip no”, the simulation continues with no problem, but the box tilts too much and the simulation gets less efficient, as indicated in the documentation for the fix deform command.

Whenever I run the same problem removing the fix rigid command, there is no problem. I have checked that the same happens using one of the examples that come with the distribution of LAMMPS. In the folder examples/rigid, in the file in.rigid, if I add the two lines:

change_box all triclinic
fix 2 all deform 1 xy erate 0.01 remap x flip yes

after the neigh_modify instructions, the same problem happens again.

I tried to search for an answer to this problem in the list, but I couldn’t find it.

By the way, I am using LAMMPS version 16Feb16. I have compiled it with -DLAMMPS_BIGBIG, just in case. The problem persists.