Problem with the new lammps

Dear all,
I recently compiled the newest version of the LAMMPS software (28Oct12). It works fine with every system that I have tried so far except the attached data file and input file. It generates the following error message. However, these data and input files work fine with the older versions of LAMMPS. I wonder if you could elaborate on that.

Err Msgs:

LAMMPS (28 Oct 2012)
Scanning data file …
2 = max bonds/atom
6 = max angles/atom
6 = max dihedrals/atom
Reading data file …
orthogonal box = (-29.9385 -29.9365 -29.9345) to (29.9385 29.9365 29.9345)
1 by 1 by 1 MPI processor grid
5100 atoms
4500 bonds
6600 angles
[maginnfe:10432] *** Process received signal ***
[maginnfe:10432] Signal: Segmentation fault (11)
[maginnfe:10432] Signal code: Address not mapped (1)
[maginnfe:10432] Failing at address: (nil)
[maginnfe:10432] [ 0] /lib64/ [0x3b13c0ebe0]
[maginnfe:10432] [ 1] ./lmp_linux(_ZN9LAMMPS_NS4Atom14data_dihedralsEiPc+0xe1) [0x488801]
[maginnfe:10432] [ 2] ./lmp_linux(_ZN9LAMMPS_NS8ReadData7commandEiPPc+0x105a) [0x84e8ba]
[maginnfe:10432] [ 3] ./lmp_linux(_ZN9LAMMPS_NS5Input15execute_commandEv+0x11e8) [0x62e6a8]
[maginnfe:10432] [ 4] ./lmp_linux(_ZN9LAMMPS_NS5Input4fileEv+0x2e7) [0x62c217]
[maginnfe:10432] [ 5] ./lmp_linux(main+0x94) [0x644514]
[maginnfe:10432] [ 6] /lib64/ [0x3b12c1d994]
[maginnfe:10432] [ 7] ./lmp_linux(_ZNSt8ios_base4InitD1Ev+0x41) [0x4735b9]
[maginnfe:10432] *** End of error message ***
Segmentation fault

I don’t know why every other example works fine except this one. Also, this one works fine with older lammps!!!

Best, (944 KB)

in.classI (1.67 KB)

your data file lacks a newline at the end - not sure why
it used to work


That certainly solved the problem. However, old version works even w/o adding a new line!!!

I fixed this - should work now even w/out a final newline.
Will be in a patch today.


Thanks Steve. I am happy that the bud was identified and the problem solved.