Problems running ASE tests

Hi,

I am having some problems running the ASE based test, which appears to be a very large fraction. I tried installing the ASE interface locally according to the instructions here:
https://pipeline.openkim.org/docs/tutorial_ase.html#installing-ase-interface-locally

However, it looks like the GIT repository is using an older KIM API (1.5) and it does not compile. Is there a newer version available?

As an alternative, I tried to install the virtual machine. That went well, until I wanted to install an actual model:

[email protected]:~$ kimitems install EAM_Dynamo_Ackland_Tichy_Au__MO_104891429740_001
Traceback (most recent call last):
  File "/home/openkim/openkim-pipeline/tools/kimitems", line 14, in <module>
    import kimapi
  File "/home/openkim/openkim-pipeline/kimapi.py", line 13, in <module>
    from packaging import version
ImportError: No module named packaging

I am most probably doing something stupid, like not installing an essential part of the system. Any insights? I did run the setup script (sudo /pipeline/runsetup) and it did install a lot of stuff.

Best regards

Jakob

Hi Jakob,

The newest version of the ASE interface has not yet been merged into master, you can find it on the branch 1.6. It should be merged soon.

For the virtual machine, I have found the issue. Apparently, the branch we were cloning from the packaging module was merged and no longer exists. To fix the issue on the box, run

sudo pip install git+https://github.com/pypa/[email protected]9542495b

Sorry for the issues, future provisioning of the virtual machines should be fixed too.

Cheers,
-Matt

Dear Matt,

Thank you very much for your help. Unfortunately, I get errors during the pip install, and I am still missing a package (now it is clj, I tried to pip install it, but it must have another name)

[email protected]:~ sudo pip install git\+https://github.com/pypa/[email protected] Downloading/unpacking git\+https://github.com/pypa/[email protected] &nbsp;&nbsp;Cloning https://github.com/pypa/packaging \(to 9542495b\) to /tmp/pip\-XnHBNN\-build &nbsp;&nbsp;Could not find a tag or branch &#39;9542495b&#39;, assuming commit\. &nbsp;&nbsp;Running setup\.py egg\_info for package from git\+https://github.com/pypa/[email protected] &nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;warning: no previously\-included files found matching &#39;\.travis\.yml&#39; &nbsp;&nbsp;&nbsp;&nbsp;warning: no previously\-included files found matching &#39;dev\-requirements\.txt&#39; &nbsp;&nbsp;&nbsp;&nbsp;no previously\-included directories found matching &#39;docs/\_build&#39; &nbsp;&nbsp;&nbsp;&nbsp;no previously\-included directories found matching &#39;tasks&#39; Installing collected packages: packaging &nbsp;&nbsp;Running setup\.py install for packaging &nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;warning: no previously\-included files found matching &#39;\.travis\.yml&#39; &nbsp;&nbsp;&nbsp;&nbsp;warning: no previously\-included files found matching &#39;dev\-requirements\.txt&#39; &nbsp;&nbsp;&nbsp;&nbsp;no previously\-included directories found matching &#39;docs/\_build&#39; &nbsp;&nbsp;&nbsp;&nbsp;no previously\-included directories found matching &#39;tasks&#39; Successfully installed packaging Cleaning up\.\.\. [email protected]\-vm:\~ kimitems install EAM_Dynamo_Ackland_Tichy_Au__MO_104891429740_001
Traceback (most recent call last):
  File "/home/openkim/openkim-pipeline/tools/kimitems", line 15, in <module>
    import kimobjects
  File "/home/openkim/openkim-pipeline/kimobjects.py", line 22, in <module>
    from template import template_environment
  File "/home/openkim/openkim-pipeline/template.py", line 19, in <module>
    import jinja2, json, clj
ImportError: No module named clj

Best regards

Jakob

Hello again,

I am continuing to have problems trying out the tests on openkim.org. I finally got “kimitems install” to work in the virtual machine after installing another package “pyclj”. It seems to me that the idea of having a virtual machine that installs the entire pipeline *after* downloading the machine may be a good idea, but it requires that the VM is continuously tested, otherwise we use the main point of the VM: that it just works, and that it produces a reproducible environment. Maybe a more “static” VM would be better, although it would need replacement when something major is changed.

Anyway, I am now able to download items with “kimitems install”, but building them does not work:

[email protected]:~ kimitems build Building all packages\.\.\. Traceback \(most recent call last\): &nbsp;&nbsp;File &quot;/home/openkim/openkim\-pipeline/tools/kimitems&quot;, line 240, in &lt;module&gt; &nbsp;&nbsp;&nbsp;&nbsp;action\_build\(\) &nbsp;&nbsp;File &quot;/home/openkim/openkim\-pipeline/tools/kimitems&quot;, line 123, in action\_build &nbsp;&nbsp;&nbsp;&nbsp;kimapi\.make\_all\(\) &nbsp;&nbsp;File &quot;/home/openkim/openkim\-pipeline/kimapi\.py&quot;, line 47, in make\_all &nbsp;&nbsp;&nbsp;&nbsp;o\.make\(\) &nbsp;&nbsp;File &quot;/home/openkim/openkim\-pipeline/kimobjects\.py&quot;, line 256, in make &nbsp;&nbsp;&nbsp;&nbsp;if not version\.Version\(self\.kim\_api\_version\) in version\.Specifier\(\_\_kim\_api\_version\_spec\_\_\): AttributeError: &#39;module&#39; object has no attribute &#39;Specifier&#39; [email protected]\-vm:\~

This looks like an internal error in the pipeline that I will not be able to fix myself. Perhaps a version mismatch between different components.

Anyhow, following Matt’s instructions (thank you again!), I got the ASE calculator installed on my local machine. However, it looks like the standard tests on the KIMitems page require the full pipeline to run. Is there some way to run these tests the same way that the openkim example tests can be run, i.e. just specify which model to use and run the test? I was planning to use these tests to verify my own Asap KIM simulator module for ASE by checking that I get the same results. Maybe it is just easier to make my own tests using both calculators.

Best regards

Jakob

Hi Jakob,

Apologies for the kimitems errors. Matt’s been busy transitioning the entire VM to the chip package handling system he created, and this must’ve slipped by. Please be patient while we resolve this. As long as you have the KIM API, python, the python-ase module, the openkim-python interface, and the KIM-ASE calculator interface installed on your local machine, you should be able to run the ASE-based Tests we currently have in the OpenKIM Repository. For example, let’s use the LatticeConstantCubicEnergy_fcc_Ar__TE_206669103745_001 Test (see ) and its corresponding Test Driver (download link also provided at the bottom of the page). Depending on how you set up and installed the KIM API, you should be able to place these anywhere you like. Looking inside of LatticeConstantCubicEnergy_fcc_Ar__TE_206669103745_001, you can see a file named ‘pipeline.stdin.tpl’ that looks like this: @< path(“LatticeConstantCubicEnergy__TD_475411767977_001”) >@ Al fcc @< MODELNAME >@ This file is a template that’s processed by the pipeline when it runs the Tests, with the @< >@ delimiters indicating things that are to be replaced. After the file is templated, the pipeline directs its contents to the Test executable on stdin. Since you don’t want to use the pipeline/VM, you can feed the appropriate data on stdin to your Test executable yourself. The first line indicates a path to the executable of the Test Driver, while the last line indicates the name of the Model being used with the Test. Thus, if you had installed the Test to /home/jakob/LatticeConstantCubicEnergy_fcc_Ar__TE_206669103745_001 and the Test Driver to /home/jakob/LatticeConstantCubicEnergy__TD_475411767977_001/, and you had a KIM Model named ‘mymodel’ installed somewhere on your machine, you could run the Test against this Model by doing something like: which should create a directory called ‘output’ in the current directory which is populated with the results of the Test-Model run. Let me know if you run into any questions/problems, Dan

Hi Jakob,

I just had a chance to checkout the issue in detail. It seems that the maintainers of packaging are moving at a quick rate and breaking things. This does point to a longer standing issue that things we thought were immutable (such as git history) can in fact be alternated. In the mean time, you can fix this by running

sudo pip uninstall packaging
sudo pip install git+https://github.com/pypa/[email protected]

Please let me know if you run into any other issues.

Dear Daniel and Matt,

Thank you for your kind help. I now have it up and running both natively and in the VM. Very useful for my development, debugging, and general poking around.

Best regards

Jakob