"read_restart" not working with "hybrid"


    A moltemplate user has emailed me because they are running into
trouble using "read_restart" in one of the examples. Apparently
"read_restart" appears to fail when the user is using "hybrid" force
field styles. Something has changed in the last 6 weeks. This is new

    I am attaching two small examples: "working.tar.gz" and
"not_working.tar.gz". Both contain 8 water molecules. If you unpack
the "not_working" example, you can reproduce the error using:

lmp_linux -i run.in.min # this creates a restart file
lmp_linux -i run.in.npt # this reads the restart file

This generates
ERROR: KSpace style is incompatible with Pair style (kspace.cpp:147)

(I am using the December 3rd version of LAMMPS.)

If you unpack the "working" example, you can run the same commands
without error. The difference between working and not_working is the
use of "hybrid" force-field styles.

Thank you in advance for looking into this.


not_working.tar.gz (1.19 KB)

working.tar.gz (1.14 KB)

Fixed this issue in the 19Jan patch - it was
actually a problem with pair hybrid, not the
restart file per se. Thanks for sending the
test cases.