Reax/c not working

Hello lammps users,

I am working with reax/c pair style. When I run my script on lammps on windows it is running fine but when I run the same script on linux it shows an error “ERROR: Unknown pair style (…/force.cpp:176)”.

What is the problem? Do I need to build reax/c package separately?? If yes plz help me making this because I m new to linux and dont have any idea how to make pakages.

thanks

Rajesh

Hello,
The error means that you have compiled lammps without reax/c. You need to recompile using command

make yes-USER-REAXC

before creating the executable.

Bartek

Phone: +46 (0)920 492163

OK. But it was installed by someone else and he is not here. I tried hard but unable to create lmp_mpi executable. I will be thankful if u can plz tell me the steps in short. I tried make mpi cmd but lmp_mpi was not updated.

Thanks.
Rajesh.

To make with any package (that doesn’t also have an auxiliary lib),
it it just:

cd lammps/src
make yes-user-reaxc # or other package name
make machine # serial, mpi, etc

Steve

Thanks Steve,

I tried this but I am getting error

[email protected]…6037…:~/lammps-16Feb16/src$ make mpi
make[1]: Entering directory /home/ap/lammps-16Feb16/src/Obj_mpi' Makefile.package.settings:5: ../../lib/reax/Makefile.lammps: No such file or directory Makefile.package.settings:7: ../../lib/poems/Makefile.lammps: No such file or directory Makefile.package.settings:8: ../../lib/meam/Makefile.lammps: No such file or directory Makefile.package.settings:12: ../../lib/gpu/Makefile.lammps: No such file or directory make[1]: *** No rule to make target …/…/lib/gpu/Makefile.lammps’. Stop.
make[1]: Leaving directory `/home/ap/lammps-16Feb16/src/Obj_mpi’
make: *** [mpi] Error 2

The errors you are getting are for the reax package, not user-reaxc.

The reax package (and poems, meam, gpu, etc) have auxiliary

libs you need to compile first, if you want to use them. (you probably

don’t want to use them, so don’t compile with those pacakges installed).

See the doc/Section_start.html page for lots of details about how

to do this.

Steve

Thanks Steve. I first compiled the poems, meam, gpu, etc. and then build the lammps. Now it works fine.
Thanks again.