Rerun - RDF

Dear Lammps Users

I have been trying to use rerun command to find the rdf of a polymer system. I think it is calculating the rdf, but not printing to the file while using fix ave/time command. I was not sure whether LAMMPS directly takes in the ix, “id” and “type” fields. When I tried to use field command of read dump, that was giving error too. I have not attached this extra part here

The script used to do so is attached. A small test version of the dump file used to read in the coordinates is also attached. Each time step has 19360 particles, but I have shown only a few lines. I have cross checked that the file contains the required timestep used for computing rdf. Also, coordinates were printed out every 100 timesteps (and I have tried to make Nevery Nfreq consistent with this)

Please find the attachments

Thanks in advance

Vaidyanathan M S

UT Austin

coord.1000000.txt (3.41 KB)

rerun.rdf (1.11 KB)

Forget the RDF for a moment. When you use the
rerun command, are you correctly reading the dump
file and printing out thermodynamic info for each
snapshot that corresponds to the log file from
the original run that produced the dump file?

Once that is working, you can instrument the
new script to calculate and output RDF info.