Segmentation fault with pair_style bop

Hi, all lammps user,

I am trying to run a simulation with pair_style bop. However, I got an error: APPLICATION TERMINATED WITH THE EXIT STRING: Segmentation fault (signal 11). I try the same simulation with other pair_style then the error was fixed. Thus, I believe the error is attributed to the pair_style bop. Does anyone can help me to solve this error?

The attachment is my input file and potential file.

Any suggestion will be appreciated.

[

谢家旺

[email protected]…127…

](https://maas.mail.163.com/dashi-web-extend/html/proSignature.html?ftlId=1&name=谢家旺&uid=xjw_thu%40163.com&iconUrl=https%3A%2F%2Fmail-online.nosdn.127.net%2Fqiyelogo%2FdefaultAvatar.png&items=["xjw_thu%40163.com"])

签名由 网易邮箱大师 定制

in.Cu-diamond (1.39 KB)

CCu_v2.bop.table (476 KB)

please always report which exact version of LAMMPS you are using and what platform you are running on.

it not need to be the pair style that is at fault here.

axel.

Thanks for your respond, axel.
The LAMMPS version is the stable version (22 Aug 2018). My platform is RedHat Enterprise Linux 5.5 x86_64.

Jacobic

[

谢家旺

[email protected]…127…

](https://maas.mail.163.com/dashi-web-extend/html/proSignature.html?ftlId=1&name=谢家旺&uid=xjw_thu%40163.com&iconUrl=https%3A%2F%2Fmail-online.nosdn.127.net%2Fqiyelogo%2FdefaultAvatar.png&items=["xjw_thu%40163.com"])

签名由 网易邮箱大师 定制

On 1/12/2020 03:19,Axel Kohlmeyer<[email protected]…24…> wrote:

Thanks for your respond, axel.
The LAMMPS version is the stable version (22 Aug 2018). My platform is RedHat Enterprise Linux 5.5 x86_64.

you should be updating both. especially the red hat is very outdated and you will have increasing difficulties compiling/installing current software on it as its default compilers are not C++11 compatible (and have many other issues).
the bop pair style in your version has a bug that causes it to report stress/pressure incorrectly. but that cannot result in a segmentation fault.

You may want to try out the attached, corrected version of the potential file, as the file you have seems to be missing data.

Axel.

CCu_v2.bop.table (476 KB)

sorry, copied from the wrong branch. this should be the corrected potential file.

axel.

CCu_v2.bop.table (476 KB)