something is wrong with Gyration radius

Dear Community,

I want to study behaviour of polymer melt,

I managed to create it using chain.f and and equilibrate it with the protocol provided by Sliozberg et al. (2012)

When equilibrated my melt exhibits correct end-to-end distance (matching the theoretical <Re^2> = C * l^2 N_monomers ( I calculate this parameter using VMD, MDanalysis tools)

It also matched the RDF provided in the paper.

But the ratio of <R_e^2>/<R_g^2> which is supposed to be equal to 6 is equal to 0.6 ( I calculate the <R_g> using Mdanalysis, Lammps and VMD)

So my Gyration radius squared is 10 times larger then the expected value.

When I transform my data file into Real units and run a normal Lammps simulation with a forcefieldwith angles,dihedrals and etc. I again get the ratio which is around 0.6

It looks like its a systematic error, but I double checked the units and everything seems to be right. This issue is universal for chains of different lengths.

Does anyone have any ideas(even intuitive ones) why it may happen?

Here is my equilibration script:

If you add “thermo_modify norm no” to your script, do you still get 6 with LJ?


I still get 0.5-0.6 since changing thermo_modify doesn’t change the coordinates output, and I calculate R_g using all three VMD, Lammps, Mdanalysis.


I am not familiar with polymer melting but have you tried to use compute gyration within Lammps itself?