Stuck while adding MDs from a local source

Hello, OpenKim users.

Because of the outdated SSL protocol of my server, I have to add MDs from a local source.

And I need some help.

According to section E.5 of the installation manual;

E.5 Adding MDs, PMs, and SMs from a local source directory

The kim-api-collections-management utility allows for the installation of items
from a directory on the local file system.  This is useful if you are
developing an item or do not have network access to openkim.org, but already
have the source code downloaded.  We'll assume that the item's source code
(including the CMakeLists.txt file, parameter files, etc) you want to install
are in directory "${WORKSPACE}/item-source".  Then you simply provide this
directory name instead of the item name.

   $ kim-api-collections-management install user "${WORKSPACE}/item-source"

but the explanation is not sufficient for me, I am not an expert.

I downloaded Tersoff_LAMMPS__MD_077075034781_005 and already installed KIM-API in another directory.

I am not sure what should I do considering the below error messages.

> [[email protected] _KIM]$ ls
> build  install.txt  kim-api-2.3.0  kim-api-2.3.0.txz  Tersoff_LAMMPS__MD_077075034781_005  Tersoff_LAMMPS__MD_077075034781_005.txz

[[email protected] _KIM]$ kim-api-collections-management install system "/home/yxj200002/_KIM/Tersoff_LAMMPS__MD_077075034781_005/"
CMake Error at CMakeLists.txt:29 (find_package):
  Could not find a package configuration file provided by "KIM-API-ITEMS"
  (requested version 2.2) with any of the following names:

    KIM-API-ITEMSConfig.cmake
    kim-api-items-config.cmake

  Add the installation prefix of "KIM-API-ITEMS" to CMAKE_PREFIX_PATH or set
  "KIM-API-ITEMS_DIR" to a directory containing one of the above files.  If
  "KIM-API-ITEMS" provides a separate development package or SDK, be sure it
  has been installed.


-- Configuring incomplete, errors occurred!

Aborting!

Thank you

I managed to solve the problem. It is very easy to solve but for someone like me in future, I left a comment about how I solved.

cmake .. -DKIM_API_INSTALL_COLLECTION=SYSTEM -DKIM-API-ITEMS_DIR="/directory/of/kim-api-items-config.cmake" -DKIM-API_DIR="/directory/of/kim-api-config.cmake"

In my case, probably because of the different installation directory of KIM-API, cmake needs extra prefixes; KIM-API_DIR, KIM-API-ITEMS_DIR.

After that following the manual worked well.