System Hanging after 'Setting up run'

Dear Lammps Users,

I met a problem where my system hangs after the input file and the data file has been read in(without any errors at this stage), and following by ‘Setting up run…’. From this moment on, there is no output data anymore. I found in the error section that ‘I need to specify an MPI setting’. But are there any other reasons than this could cause the hanging problem like this?

Thanks very much for your help!

Please post a simple (small) example that illustrates the problem.
Can you run past this point on 1 processor?


Hi Steve,

I haven’t tried to run on a single processor, but will do this right now.

I attached the screen output as well as the read_data file here, and I will keep on debugging. If you have any thoughts on what’s going wrong here, please let me know as well.

Thanks very much for your help!

screen_output (1.63 KB)

NPinmeltDilute1 (69.2 KB)

I ran on a single processor, and it’s working! I don’t know why it fails on a multi processor?

Thanks a lot for guiding me there!