system is not minimizing

Hi there, I have a problem with minimizing energy of system in lammps. I tried different minimize methods but they do not give me desired results. I saw people made good results with cg minimization in literature with the same potentials but it does not work in my simulations.

Geometry of system does not matter and it does not minimize its energy despite how I place atoms. I use potentials for Fe and He.

Here is fragment of my lammps code:

---------- Initialize Simulation ---------------------

units metal
dimension 3
boundary p p p
atom_style atomic

---------- Create Atomistic Structure ---------------------

lattice bcc 3
region whole block 0.000000 13.41640786 -67.08203932 67.08203932 0.000000 6 units box
create_box 3 whole
region upper block INF INF 0.000000 INF INF INF units box
lattice bcc 3 orient x 0 1 -2 orient y 0 2 1 orient z 1 0 0
create_atoms 1 region upper
region lower block INF INF INF 0.0 INF INF units box
lattice bcc 3 orient x 0 1 2 orient y 0 -2 1 orient z 1 0 0
create_atoms 2 region lower
group upper type 1
group lower type 2

lattice fcc 3.3 orient x 1 0 0 orient y 0 1 0 orient z 0 0 1
region hel block INF INF -1 4 INF INF units box

region hel2 block INF INF 66 68 INF INF units box

create_atoms 3 region hel

create_atoms 3 region hel2

group hel region hel

group hel2 region hel2

group lower region lower
group upper region upper
group upper type 1
group lower type 2
group hel type 3

---------- Define Interatomic Potential ---------------------

pair_style hybrid table linear 3027 beck 8.0 eam/alloy
pair_coeff * * eam/alloy FeCr.eam.alloy Fe Fe Fe
mass 3 4.002602
pair_coeff 1 3 table HeFe.pot MORSE_FE_HE 6.0
pair_coeff 2 3 table HeFe.pot MORSE_FE_HE 6.0
pair_coeff 3 3 beck 398.7 0.0000869 0.675 4.390 0.0003746 6.0
neighbor 5.0 bin
neigh_modify delay 10 check yes

---------- Displace atoms and delete overlapping atoms -----

displace_atoms upper move 0 0 0 units lattice
delete_atoms overlap 1.5 lower upper
delete_atoms overlap 1.5 upper hel
delete_atoms overlap 1.5 lower hel

write_data krysztal.txt

---------- Define Settings ---------------------

compute csym all centro/atom fcc
compute eng all pe/atom
compute eatoms all reduce sum c_eng

---------- Run Minimization ---------------------

reset_timestep 0
thermo 10
thermo_style custom step pe lx ly lz press pxx pyy pzz c_eatoms
fix 1 all box/relax iso 0 vmax 0.001
fix_modify 1 energy yes
dump 1 all cfg 25 dump.sig5_minimization_*.cfg id type xs ys zs c_csym c_eng fx fy fz
dump_modify 1 element Fe Fe He
min_style cg
minimize 1e-115 1e-115 15000 15000
undump 1

I appreciate every advice.

Thank you in advance.

What does “does not give desired results” mean?

An error, a bad energy, non-convergence, something else?

How do you know the answer is “wrong” ?


I apologize for not clear statement.

Atoms in my system do not change their position. I set lattice constant 3 for iron and 3.3 for helium so their positions can not be correct. Minimization also ends after 1 iteration and 30 force evaluations.

I tried to use different min styles so the result was better, but the only styles where iron lattice constant changed were quickmin and fire. In my opinion this is confirmation of my theory, but unfortunately those styles do not support fix box/relax and after minimization I get two free surfaces instead of grain boundary.

You may try hftn; worked for me when cg failed.
Lammps documentation says: " In most cases the behavior of hftn is similar to cg, but it offers an alternative if cg seems to perform poorly"
Btw, cg is the default min_style, so you really do not need to declare it.

– Abrar

@ Abrar Quadery

Unfortunately I tried every min style lammps has to offer and it still does not help.

Thank you for reply

Please post a simple (small) input script and data file
that illustrates the problem. Also the output of the

log file. The minimizer states at the end of the minimize
why it stopped.