There is an error with the GPU implemented

Dear all

I installed the LAMMPS-18Dec2018 and successfully added the GPU package. When I run the script with GPU, it is OK.

However, today I install the LAMMPS-29Sep2021 and successfully add the GPU package.
but when I run the script with GPU, There is an error.

Could anybody help me to check the problem?

>>/home/dell/Softrun/cp2k-8.2.0/tools/toolchain/install/openmpi-4.0.5/bin/mpirun -np 8 /home/dell/Softrun/lammps-29Sep2021/src/lmp_mpi -sf gpu -pk gpu 8 < in.deposit.molecule

LAMMPS (29 Sep 2021 - Update 1)


  • UCL Error: Error compiling PTX Program…*
    *[dell-PowerEdge-T630:54598] *** Process received signal ****
    [dell-PowerEdge-T630:54598] Signal: Segmentation fault (11)
    [dell-PowerEdge-T630:54598] Signal code: Address not mapped (1)
    [dell-PowerEdge-T630:54598] Failing at address: (nil)

The all error information is attached.

error.txt (16.5 KB)

There is not enough information here to provide any meaningful help.
The most likely scenario would be that you have some inconsistent software installation (e.g. you are using a newer CUDA toolkit than what the CUDA driver of the operating system supports). Other explanations could be incorrect settings when compiling the GPU support.
We are regularly compiling and running LAMMPS with CUDA, so it is unlikely that this is a general error in LAMMPS itself.

You need to describe in detail the versions of the tools and the exact steps that you did to compile LAMMPS. If you have used the traditional build system to compile LAMMPS, please try using the CMake route.


Thank you.

I have used the traditional build system to compile LAMMPS. So I will try using the CMake.