TIP4P/2005 water in dlpoly

Hi everyone,

I am trying to simulate a system that consists of water in a catalyst pore. My catalyst slab with adsorbate is frozen with free water molecules (TIP4P/2005) on top. I tried with 2 different versions of dlpoly (4.03.4 & 4.09) and I face the following issues-

  1. In version 4.09, the simulation runs okay with rigid body TIP4P/2005 water molecules but the total energies are diverging (shoots up). I ran the simulation for 5 nanoseconds and the energy still doesn’t converge. Later I tried to use the constrained body dynamics instead of treating water as rigid body, but that shows error message 644, i.e., the system is over constrained.
  2. In version 4.03.4, using the same water model, I get the error message 642 that says rigid body unit diameter is greater than system cutoff. I was using a 12 Å cutoff, so I increased that up to 22 Å, but it shows the same error message. I can’t increase it further due to my system size.

The following is how I define water molecules as rigid body in the FIELD file,

TIP4P/2005 water molecules
nummols 641
atoms 4
Ow 16.0000 0.0000
Hw 1.0000 0.5564
Hw 1.0000 0.5564
Om 0.0000 -1.1128
rigid 1
4 1 2 3 4

I have previously simulated TIP3P water with constraints in similar scenario without any issue.
Can you please share your experience about working with TIP4P water in dlpoly? Thank you so much!

To unsubscribe from the DLPOLY list, click the following link:

Hi Saleheen,

can you send the inputs to [email protected].
also the output file if you have it.


Without Questions there are no Answers!

Hi Elena,
I have sent the inputs as well as outputs (except the trajectory file) to the email you provided. Please let me know if you received them. Your help is much appreciated.
Thank you!

Hi Elena,

An update, the simulations seem to be fine running on 1, 2, & 4 cores. Any number of cores above that and the simulation diverges. Please let me know if you need anything from me to look into this issue.

Thank you,