I apologize for a possibly stupid question.
Not at all a stupid question. I'm sure others will have the same question.
After a while being unable to work seriously on KIM, I am trying
to install the latest version of KIM API package, but it fails
due to the version of gfortran installed on my machine (now 4.4.7).
The installer says version 4.7.0 or higher is needed, but is there
any way to get around this problem? To install 4.7.0 or higher I
need to update the entire linux system (currently CentOS6), which
If you want to disable the KIM API build checks on the gfortran version number, then you can comment out lines 41--49 in the file build_system/Makefile.SanityCheck
However, the latest KIM API has not been tested with these compilers. In the past, we have experienced some trouble with the older compilers and you may find that it doesn't work or works incorrectly.
Alternatively, you may be able to download and build gcc version 4.8 from source, instead of using the CentOS package manager. This is typically not a difficult task, but it can take up to a few hours on some machines to compile.
Keep us updated on your progress and we'll try to help as much as we can.