"Type mismatch" error when parallel compile gulp-6.0 with gcc12

Hi gulp teams,

I am trying to compile parallel using ‘./mkgulp -m’ command under a conda environment, here is my conda list:

and I received these errors:

I google this kind error and it told me that is because my gcc version is too high. I also tried to add:
FCFLAGS="-w -fallow-argument-mismatch -O2"
FFLAGS="-w -fallow-argument-mismatch -O2"
in mkgulp file to fix it, but those two command doesn’t work.

I need your help.

I find how to solve this error now in mkgulp files:

but now a new error happened:

/home/cbh/anaconda3/envs/gulp/bin/…/lib/gcc/x86_64-conda-linux-gnu/12.1.0/…/…/…/…/x86_64-conda-linux-gnu/bin/ld: harmonicrelax.o: undefined reference to symbol ‘dspmv_’
/home/cbh/anaconda3/envs/gulp/bin/…/lib/gcc/x86_64-conda-linux-gnu/12.1.0/…/…/…/…/x86_64-conda-linux-gnu/bin/ld: /home/cbh/anaconda3/envs/gulp/lib/./liblapack.so.3: error adding symbols: DSO missing from command line

I checked my lib and I’m sure that I have /liblapack.so.3 installed, so I don’t know how ti=o deal with this new problem now.

I solved the DSO missing problem by adding --copy-dt-need-entries