Unable to install a model driver, potential model by using Kim-api-collections-management

Hello OpenKIM users,

after installing KIM api on a machine, I tried to install MDs and PMs to the user collection.

but every time I failed to do so with the below error message.

$ ./kim-api-collections-management install user LJ_Shifted_Bernardes_1958HighCutoff_Ar__MO_242741380554_003
*** ERROR *** Unable to successfully contact openkim.org to check LJ_Shifted_Bernardes_1958HighCutoff_Ar__MO_242741380554_003 compatibility.
              'wget' returned error code 5.

Could you help me solve this issue?

Can it be related to the permission status? I am not an admin user on the machine I am using.

But wget is completely fine for others, I tested it and it worked well like below;

$wget https://github.com/lammps/lammps/archive/stable_3Mar2020.tar.gz

--2022-11-01 11:52:28-- https://github.com/lammps/lammps/archive/stable_3Mar2020.tar.gz

Resolving github.com (github.com)...

Connecting to github.com (github.com)||:443... connected.

HTTP request sent, awaiting response... 302 Found

Location: https://codeload.github.com/lammps/lammps/tar.gz/refs/tags/stable_3Mar2020 [following]

--2022-11-01 11:52:28-- https://codeload.github.com/lammps/lammps/tar.gz/refs/tags/stable_3Mar2020

Resolving codeload.github.com (codeload.github.com)...

Connecting to codeload.github.com (codeload.github.com)||:443... connected.

HTTP request sent, awaiting response... 200 OK

Length: unspecified [application/x-gzip]

Saving to: ‘stable_3Mar2020.tar.gz’


I’m not completely sure what the issues is, but it appears to be associated with SSL certificates. Our best guess is that the machine you are using has an outdated version of wget or openssl and would need to be upgraded to obtain the latest security updates.

Thank you for the reply,

may I ask what versions are required?

The versions installed on my machine are

wget ~ 1.14
openssl ~ 1.0.2k-fips 26 Jan 2017

Dr. Relliott,

I did research to understand the reason of the error.

I don’t think, the error is because of the version of wget.

Again, on my server machine, when I try to install MDs or PMs, I failed just like below;

./kim-api-collections-management install user Morse_Shifted_Jelinek_1972_Ar__MO_831902330215_003
*** ERROR *** Unable to successfully contact openkim.org to check Morse_Shifted_Jelinek_1972_Ar__MO_831902330215_003 compatibility.
              'wget' returned error code 5.

The same install command works perfectly on my local machine;

kim-api-collections-management install user Morse_Shifted_Jelinek_1972_Ar__MO_831902330215_003

Downloading.............. Morse_Shifted_Jelinek_1972_Ar__MO_831902330215_003

This item needs its driver 'Morse_Shifted__MD_552566534109_003', but it is not currently installed.

Trying to find it at openkim.org.

Downloading.............. Morse_Shifted__MD_552566534109_003

**Consolidate compiler generated dependencies of target Morse_Shifted__MD_552566534109_003**

[100%] Built target Morse_Shifted__MD_552566534109_003

Install the project...

-- Install configuration: "Release"

-- Installing: /Users/mangoman/.kim-api/2.3.0+AppleClang.AppleClang.GNU.2022-03-17-23-01-36/model-drivers-dir/Morse_Shifted__MD_552566534109_003/libkim-api-model-driver.so

**Consolidate compiler generated dependencies of target Morse_Shifted_Jelinek_1972_Ar__MO_831902330215_003**

[100%] Built target Morse_Shifted_Jelinek_1972_Ar__MO_831902330215_003

Install the project...

-- Install configuration: "Release"

-- Installing: /Users/mangoman/.kim-api/2.3.0+AppleClang.AppleClang.GNU.2022-03-17-23-01-36/portable-models-dir/Morse_Shifted_Jelinek_1972_Ar__MO_831902330215_003/libkim-api-portable-model.so


For the debugging purpose, I modified kim-api-collections-management and got the actual string used for checking item compatibility on my server machine.

Below is the string I got;

wget --user-agent kim-api-collections-management-(2.3.0+GNU.GNU.GNU--Linux-3.10.0-957.27.2.el7.x86_64-x86_64) -q -O - --post-data
query={"kimcode":"Morse_Shifted_Jelinek_1972_Ar__MO_831902330215_003"}&fields={"kim-api-version":1}&database=obj&history=on https://query.openkim.org/api

That will go on the 161st line of kim-api-collections-management. I am using the 2.3.0 version.

version=“${web_tool_query} "${query}" https://query.openkim.org/api

Something is wrong with that string because I manually tried to get a query result like below

wget --user-agent kim-api-collections-management-(2.3.0+GNU.GNU.GNU--Linux-3.10.0-957.27.2.el7.x86_64-x86_64) -q -O - --post-data query={"kimcode":"Morse_Shifted_Jelinek_1972_Ar__MO_831902330215_003"}&fields={"kim-api-version":1}&database=obj&history=on https://query.openkim.org/api

-bash: syntax error near unexpected token `('

wget command above fails on my local machine also.

I have been through some difficulties while installing KIM-API on my server machine. I believe that something goes during the installation. Could you give me some comments that can be useful to find out what is the problem?

I was wrong. You were correct. The version of wget is the problem, I will contact the assist team for solving the issue. Thank you again!