Unable to run LAMMPS due to too many lines in input file

​nobody can debug such a "monster" (in size of script lines and in size of
the system), and most definitely nobody on this mailing list will do this.
i also see things and features that could be disabled (e.g. tiled
communication, load balancing), since they are optional.
you are just asking for trouble.

have you tested whether your approach will work with a much(!) smaller test
system before embarking on this massive simulation?
what exactly is the reason why you define so many regions and fixes?
couldn't you just use fix efield with atom style variables?

please note, that LAMMPS has no limit as to the number of lines (or the
length of a line).
you may be hitting a limit of the MPI library. are you using the -in flag
or I/O redirection?


Dear Dr. Kohlmeyer,

Thank you for a prompt reply. I model the emission of ionic liquid through an efield generated by a Laplace solver generating regions with varying eField strengths. This pretty much makes it necessary to have these many regions and fixes.

But you did manage to solve my problem. I was using the command “ibrun ./lmp_knl < test_coarse.in” which caused the code to hang up. However, when I use “ibrun ./lmp_mpi -in test_coarse.in” the code started working.

You are awesome.
Thank you so much.